[GeoSciML] setting up new EA version configuration for geosciML v4 ogc

Steve Richard steve.richard at azgs.az.gov
Mon Aug 20 18:37:16 EDT 2012


I've exported all the app schema in the version 4 project we were working on
in Wellington. See the repository at 

https://www.seegrid.csiro.au/subversion/GeoSciML/branches/4.0.0

there's a subdirectory for each of the current app schema parts, with a UML
subfolder in each that contains the XMI exported from EA.  The whole
project, cleaned up post Wellington, is exported to an xmi (GeoSciML4.xml)
in the branches/4.0.0/eap directory, but this is for reference only. You can
import it to have a look at the class layout and refactoring, and use of the
abstractDescription decoupling pattern.

 

I need some help on setting up a version configuration/eap project in the
branches/4.0.0/model directory that uses the version-controlled xmi for each
of the component packages so we've got the whole thing under version
control.  I'm not sure how to do that, and am out of time right now to work
on it. Can someone else who know's the trick get the final version
configuration set up?

 

Thanks

steve

 

 

Stephen M Richard

Arizona Geological Survey

416 W. congress #100

Tucson, AZ

AZGS: 520-770-3500

Office: 520-209-4127

FAX: 520-770-3505

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/geosciml/attachments/20120820/36d27482/attachment.htm>


More information about the GeoSciML mailing list